(retour page principale), (IDL et GDL), (Tutoriel GDL).

Léa Noreskal
Mai 2010

Autres documents d'aide à la compilation de GDL: sous OSX (OSX 10.5.6), sous CentOS (5.4/5.5 ou 5.7)

Compiler GDL sous Mac OSX 10.6.3

Ce document reproduit les étapes suffisantes pour compiler GDL-0.9rc4 sur un système Mac OSX 10.6.3 en ajoutant Readline 6.1, GSL 1.14, PLplot 5.9.5 (et cmake 2.8.1 nécessaire pour compiler plplot). Une première version pour la compilation de GDL sous Mac OSX 10.5.6 est disponible ici .

Les différentes étapes ont été realisées en tant que simple utilisateur. Avant de commencer, assurez vous d'avoir X11 et Xcode installés ainsi que le X11 forwarding activé. Si ce n'est pas le cas, les étapes sont expliquées sur la page de compilation sous Mac OSX 10.5.6 ici

Version

En mode console, la commande magique sous OSX pour connaitre la version du système est sw_vers

$ sw_vers
ProductName: Mac OS X
ProductVersion: 10.6.3
BuildVersion: 10D573

Readline 6.1

GDL "nécessite" au moins la version 5.2 pour tout avoir (complétion, historique, ...).
Pour la version utlisée ici, il n'y a aucune modification particulière à effectuer. Il suffit de décompresser l'archive puis d'effectuer make et make install

$ tar -zxf readline-6.1.tar.gz
$ cd readline-6.1
$ mkdir Compilation
$ ./configure --prefix=/Users/lea/GDL/readline-6.1/Compilation/
$ make
$ make install
$ cd ..

La GSL

La seule vraie ruse ici est de bien ajouter la librairie dynamique comme il faut (via la variable DYLD_LIBRARY_PATH). Je recommande de faire les tests (make check).

$ curl ftp://ftp.gnu.org/gnu/gsl/gsl-1.14.tar.gz > gsl-1.14.tar.gz
$ mv gsl-1.14.tar.gz GDL/
$ cd GDL/
$ tar -zxf gsl-1.14.tar.gz
$ cd gsl-1.14
$ mkdir Compilation
$ ./configure --prefix=/Users/lea/GDL/gsl-1.14/Compilation/
$ make
$ make install
$ make check
$ export DYLD_LIBRARY_PATH=/Users/lea/GDL/gsl-1.14/Compilation/lib

Compilation de Cmake

Les dernières versions de plplot nécessitent Cmake ...

$ curl http://www.cmake.org/files/v2.8/cmake-2.8.1.tar.gz > cmake-2.8.1.tar.gz
$ tar -zxf cmake-2.8.1.tar.gz
$ cd cmake-2.8.1
$ ./bootstrap
$ make

En resumé, après avoir telechargé et decompressé l'archive Cmake, et etre allé dans le répertoire ou Cmake a été extrait il y a 2 étapes: bootstrap et make. Comme on va vivre en local, on n'a pas besoin de faire un make install.

les résultats (cmake et ccmake) sont posés dans ./bin

Compilation de plplot

Récuperation et compilation de Pplot (nécessite Cmake ...)

$ tar -zxf plplot-5.9.5.tar.gz
$ cd plplot-5.9.5/
$ mkdir Compilation
$ cd Compilation
$ ../../cmake-2.8.1/bin/cmake -DCMAKE_INSTALL_PREFIX=. -DCMAKE_VERBOSE_MAKEFILE=ON -DENABLE_python=OFF -DPLD_wxwidgets=OFF ..
$ make
$ make install

Des problèmes de compilations ont été rencontré avec Python et wxwidgets, d'où leurs désactivation...

Compilation de GDL

$ tar -zxf gdl-0.9rc4.tar.gz
$ cd gdl-0.9rc4
$ ./configure \
     --with-plplotdir=/Users/lea/GDL/plplot-5.9.5/Compilation/ \
     --with-gsl=/Users/lea/GDL/gsl-1.14/Compilation/ \
     --with-readlinedir=/Users/lea/GDL/readline-6.1/Compilation/ \
     --with-Magick=no --with-python=no \
     --with-netcdf=no --with-hdf=no --with-hdf5=no
$ make
$ make check

Un executable gdl devrait etre disponible dans le sous-repertoire src/.

Lancement de GDL

Si on ne change pas de repertoire, il suffit de lancer via:

$ ./src/gdl
ou
$ sh ./quick_start_GDL.sh

Attention, en lançant a partir de ./src/gdl, on a accès seulement aux procédures et fonctions intrinseques à GDL, on ne charge pas les programmes disponibles sous src/pro/.

Pour avoir accès aux programmes des répertoires src/pro/ et testsuite ( suite de test ) , il faut lancer le script quick_start_GDL.sh

Compilation de la version CVS de GDL

Avant d'effectuer les manipulations suivantes, il faut être en possesion d'une version CVS de GDL. Dans le répertoire courant de la version à compiler faire les manipulations suivantes:


$ ./configure \ --with-plplotdir=/Users/lea/GDL/plplot-5.9.5/Compilation/ \
     --with-gsldir=/Users/lea/GDL/gsl-1.14/Compilation/ \
     --with-readlinedir=/Users/lea/GDL/readline-6.1/Compilation/ \
     --with-Magick=no --with-python=no \
     --with-netcdf=no --with-hdf=no --with-hdf5=no
$ make
$ make check

Il est possible d'avoir des erreurs à en lançant make.
Ce problème est causé à l'execution de libtool par une redondance des noms des fichiers suivants :

Pour finaliser la compilation, relancez libtool en copiant la partie : " /bin/sh ../libtool ..." en ne laissant qu'une fois le nom des fichiers cités ci-dessus.

Le lancement se fait de la même façon que précédemment.